这是通达信的源码,墨大老师的寻龙诀,请帮忙改为 益盟操盘手的源码,谢谢

[其 他] 6074 7
设置
3985238 Lv.2

专栏

发表于 2022-7-16 11:53 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
这是通达信的源码,墨大老师的寻龙诀,请帮忙改为 益盟操盘手的源码,谢谢


N=10
N1=8
MN=84
NN=1.7



XA_188:=EMA(CLOSE,9);
主升浪1:=EMA(XA_188*1.14,5),COLORGREEN;
主升浪4:=EMA(CLOSE,2),COLORRED;
STICKLINE(主升浪4>=主升浪1,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),3,0),COLOR545454;



主升:EMA(COST(99),10){,PRECISION2,LINEDOT},COLORGREEN,DOTLINE;
{多数成本}
强弱分界:EMA(COST(85),10){,PRECISION2,LINEDOT},COLORRED;

{成本}
CB1:=EMA(COST(5),5);
CB2:=EMA(COST(13),5);
CB3:=EMA(COST(34),5);
CB4:=LLV(CB1,34);
CB5:=LLV(CB2,34);
CB6:=LLV(CB3,34);
CB7:=EMA(C,5);
CB8:=LLV(CB7,34);
一关:IF(CB1>CB4,CB1,CB4){,PRECISION2},COLORBLUE;
二关:IF(CB2>CB5,CB2,CB5){,PRECISION2},COLORGREEN;
三关:IF(CB3>CB6,CB3,CB6){,PRECISION2},COLORMAGENTA;
冲关:=IF(CB7>CB8,CB7,CB8),COLORF000FF,LINETHICK2;

DRAWBAND(强弱分界,RGB(80,00,20),
主升,RGB(60,60,18));
DRAWBAND(强弱分界,RGB(30,30,0),
三关,RGB(30,30,0));
DRAWBAND(三关,RGB(60,0,0),
二关,RGB(60,0,0));
DRAWBAND(二关,RGB(90,00,20),
一关,RGB(90,00,20));

DRAWKLINE(H,O,L,C);


RM3:(REF(MA(C,3),1))*1.007,COLOR00FFFF;
K99:=((EMA(KDJ.K,3)-50)*2);
IF(K99>REF(K99,1),RM3,DRAWNULL),COLORF000FF;{红线}
IF(K99>REF(K99,1),RM3,DRAWNULL),POINTDOT,COLOR0000FF,LINETHICK3;{红点};



DRAWTEXT_FIX  (1,0.58,0.02,8,'莸利比例:'),COLORLIMAGENTA;
DRAWNUMBER_FIX(1,0.63,0.02,8,CONST(WINNER(C )*100)),COLORLIMAGENTA ;




无量停板7:MA(C,5)>REF(MA(C,5),1) AND C/REF(C,1)>1.099 AND V<MA(V,5)COLOR7210CD;

STICKLINE(无量停板7,C,O,2,0) ,COLOR7210CD;

明涨停:C*1.1,COLORRED,NODRAW;

今涨停:REF(C,1)*1.1,NODRAW;

明涨停1:= CONST(明涨停),COLORWHITE,POINTDOT;{现价线};


{最长筹码线}
X_36:=COST(1);
X_37:=COST(10);
X_38:=COST(20);
X_39:=COST(30);
X_40:=COST(40);
X_41:=COST(50);
X_42:=COST(60);
X_43:=COST(70);
X_44:=COST(80);
X_45:=COST(90);
X_46:=COST(99);
X_47:=COST(5);
X_48:=COST(15);
X_49:=COST(25);
X_50:=COST(35);
X_51:=COST(45);
X_52:=COST(55);
X_53:=COST(65);
X_54:=COST(75);
X_55:=COST(85);
X_56:=COST(95);
X_57:=X_47-X_36;
X_58:=X_37-X_47;
X_59:=X_48-X_37;
X_60:=X_38-X_48;
X_61:=X_49-X_38;
X_62:=X_39-X_49;
X_63:=X_50-X_39;
X_64:=X_40-X_50;
X_65:=X_51-X_40;
X_66:=X_41-X_51;
X_67:=X_52-X_41;
X_68:=X_42-X_52;
X_69:=X_53-X_42;
X_70:=X_43-X_53;
X_71:=X_54-X_43;
X_72:=X_44-X_54;
X_73:=X_55-X_44;
X_74:=X_45-X_55;
X_75:=X_56-X_45;
X_76:=X_46-X_56;
X_77:=MIN(X_57,MIN(X_58,MIN(X_59,MIN(X_60,MIN(X_61,MIN(X_62,MIN(X_63,MIN(X_64,MIN(X_65,MIN(X_66,MIN(X_67,MIN(X_68,MIN(X_69,MIN(X_70,MIN(X_71,MIN(X_72,MIN(X_73,MIN(X_74,MIN(X_75,X_76)))))))))))))))))));
X_78:=IF(X_57=X_77,(X_47+X_36)/2,IF(X_58=X_77,(X_47+X_37)/2,IF(X_59=X_77,(X_48+X_37)/2,IF(X_60=X_77,(X_48+X_38)/2,IF(X_61=X_77,(X_49+X_38)/2,IF(X_62=X_77,(X_49+X_39)/2,IF(X_63=X_77,(X_50+X_39)/2,IF(X_64=X_77,(X_50+X_40)/2,IF(X_65=X_77,(X_51+X_40)/2,IF(X_66=X_77,(X_51+X_41)/2,IF(X_67=X_77,(X_52+X_41)/2,IF(X_68=X_77,(X_52+X_42)/2,IF(X_69=X_77,(X_53+X_42)/2,IF(X_70=X_77,(X_53+X_43)/2,IF(X_71=X_77,(X_54+X_43)/2,IF(X_72=X_77,(X_54+X_44)/2,IF(X_73=X_77,(X_55+X_44)/2,IF(X_74=X_77,(X_55+X_45)/2,IF(X_75=X_77,(X_56+X_45)/2,(X_56+X_46)/2)))))))))))))))))));
筹码峰线:X_78,NODRAW,COLOR00EEEE;
STICKLINE(ISLASTBAR,筹码峰线,筹码峰线*1.0001,30,0),COLORYELLOW;

{量王}
总量:=AMOUNT,VOLSTICK;
量比:=V/REF(MA(V,5),1),COLORBROWN,NODRAW;
几倍:=1.9;
倍量量王:= 总量 >=REF(总量,1)*几倍 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;

天量:=总量=HHV(总量,120), COLORRED;
量王:天量&&倍量量王&&量比>2&&(BARSCOUNT(C)+1)>120,COLORGREEN;

STICKLINE(量王,C,O,1,0),COLORGREEN;


{炸板}
KCBB:=IF(CODELIKE('68') OR CODELIKE('30'),1,0);
ZF0:=IF(KCBB=1,1.195,1.093);
炸板1:=H>REF(C,1)*ZF0 AND C<H;
涨停10:=C>REF(C,1)*ZF0;
炸板2:=IF(炸板1 AND NOT(涨停10),1,0);
LX11:=BARSLAST(炸板2>0);
炸板3:IF(炸板1 AND NOT(涨停10),H*1,DRAWNULL),CIRCLEDOT,COLORFF00FF,LINETHICK1;
炸板:=IF(CURRBARSCOUNT<=CONST(LX11)+1,CONST(REF(H,LX11)),DRAWNULL);
STICKLINE(炸板,炸板,炸板,-1,0),,COLOR7CAE39;




涨幅:=(C-REF(C,1))/REF(C,1)*100;
梯量:=EVERY(C>O,3) AND  EVERY(C>REF(C,1),2) AND EVERY(V>REF(V,1),2) AND SUM(涨幅,3)<15;
DRAWTEXT(FILTER(梯量,2),H,'T3'),COLOR888888;
BK:=BARSLAST(CURRBARSCOUNT=CONST(BARSLAST(FILTER(梯量,2)))+1),LINETHICK1,COLORD355BA;
T3:REF(H,BK),LINETHICK1,COLORD355BA;

启432:=DYNAINFO(3)*1.0432;
STICKLINE(启432  AND ISLASTBAR,启432,启432,3,1),COLORFF9933;
DRAWTEXT(ISLASTBAR,启432,STRCAT('   ',CON2STR(启432,2))),COLORFF9933;
止432:REF(C,1)*0.9568,NODRAW,COLORFF9933 ;
STICKLINE(止432  AND ISLASTBAR,止432,止432,3,1),COLORFF9933;
DRAWTEXT(ISLASTBAR,止432,STRCAT('  ',CON2STR(止432,2))),COLORFF9933;




X_1:=150;
X_2:=3;
X_3:=REF(HHV(HIGH,X_1),X_2);
X_4:=REF(LLV(LOW,X_1),X_2);
X_5:=X_3-(X_3-X_4)*0.618;
X_6:=REFDATE(X_5,DATE);
横盘天数:=BARSLASTCOUNT(CLOSE<X_6),COLORGREEN;
X_7:=CROSS(CLOSE,X_6);
X_8:=横盘天数>100;
X_9:=REF(X_8,1);
X_10:=X_9 AND X_7;
X11:=BARSLAST(X_10>0);
X12:=REF(H,X11)COLOR0066BB,LINETHICK2;
;
X13:=CROSS(C,X12) AND C/REF(C,1)>1.07 AND X11>2;
X14:=C>X12 AND REF(L,1)<X12 AND  C/REF(C,1)>1.07 AND X11>2;
X15:=X13 OR X14;
X16:=FILTER(X15,3);
X17:=C>X12 AND C/REF(C,1)>1.09;
X18:=FILTER(X17,20);
DRAWICON(X_10,L*0.99,16);
STICKLINE(X12,X12,X12,-1,0),,COLORGREEN;


DRAWTEXT_FIX(CURRBARSCOUNT=1,0.9,0.1,1,EXTERNSTR(0,9997));  { 涨停原因}
DRAWTEXT_FIX(1,0.01,0.05,0,'板块:')COLOR0066BB;
DRAWTEXT_FIX(1,0.03,0.05,0,STRCAT(STRCAT(STRCAT(STRCAT(HYBLOCK,'_____'),GNBLOCK),'__'),DYBLOCK))COLOR0066BB; {板块信息}
DRAWTEXT_FIX(1,0.01,0.10,0,'同花:')COLORLIGREEN; {同花顺}
DRAWTEXT_FIX(1,0.03,0.10,0,EXTERNSTR(0,9886))COLORYELLOW;

DRAWTEXT_FIX(1,0.03,0.25,0,EXTERNSTR(0,9601))COLOR70DB93 ;
DRAWTEXT_FIX(1,0.01,0.15,0,'游资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.03,0.15,0,EXTERNSTR(0,9701))COLOR0000FF; {游资协战席位};

{量王后划线--量王的第2天是高量。大概率是短顶。除非今天返包,真正突破要突破这一根线}
大额:=总量>REF(总量,1);

量王后:REF(量王,1) AND 大额,COLORFF66CC;
DRAWLINE(量王后,H,REF(量王后,1),REF(H,1),1),COLORMAGENTA,DOTLINE;{紫色-量王后最高价划线};

三阴:=REF(DOWNNDAY(CLOSE,3),1);
收阳:=C>REF(C,1) AND C>=O;
止跌:=三阴 AND 收阳;

D4:REF(H,BARSLAST(CONST(BARSLAST(止跌))+4=CURRBARSCOUNT)),COLORYELLOW,DOTLINE;




本帖寻求各位老师的解答

回复被采纳后将获得奖励 共享币 5 个 ,目前已有 7 个回复 我来解答
来自 安徽省滁州市

举报

使用道具 扔鸡蛋

3985746
Lv.2

专栏

发表于 2022-7-16 20:52 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南京市

举报

使用道具 点亮 支持 扔鸡蛋

3985746
Lv.2

专栏

发表于 2022-7-16 17:23 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南京市

举报

使用道具 支持 扔鸡蛋

3985238
Lv.2

专栏

发表于 2022-7-16 16:45 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省滁州市

举报

使用道具 点亮 支持 扔鸡蛋

3985238
Lv.2

专栏

发表于 2022-7-16 16:40 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省滁州市

举报

使用道具 点亮 支持 扔鸡蛋

3985746
Lv.2

专栏

发表于 2022-7-16 16:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南京市

举报

使用道具 支持 扔鸡蛋

3985746
Lv.2

专栏

发表于 2022-7-16 16:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南京市

举报

使用道具 支持 扔鸡蛋

3985238
Lv.2

专栏

发表于 2022-7-16 14:12 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省滁州市

举报

使用道具 点亮 (1) 支持 扔鸡蛋

您需要登录后才可以回帖

本版积分规则 《免责声明》

楼主
8楼
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表