各位老师好,合并两个分时图主图公式,第二组指标的信号能够在第一组显示,谢谢老师

[通达信] 5555 2
设置
3584989 Lv.2

专栏

发表于 2022-7-12 12:25 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
任务编号:10151764 悬赏任务10金钻 悬赏任务 : 按甲方需求进行任务后提交稿件,被采纳后即获得佣金。

各位老师好,合并两个分时图主图公式,第二组指标的信号能够在第一组显示,谢谢老师

距截止: 任务已圆满完成 甲方已托管赏金:10 金钻
甲方发布需求22.07.12 甲方托管佣金22.07.12 威客投稿22.07.13 甲方开始选稿22.07.13 任务完成22.07.23

任务大厅共需1个合格投稿 | 每稿将获得10 金钻 | 交稿后不可编辑,被拒稿后才可再次交稿。

投诉举报 联系Ta 我来承接 已有2 个投稿 | 已采纳1 稿 | 拒绝1 稿 | 目前中标名额已满

任务需求:


合并两个分时图主图公式。第一组公式,一个引用公式和一个使用公式,把第二组公式合并到第一组,合并后的指标能显示第二组指标的买卖信号,就是那个金黄色信号和那个紫色信号,我自己每天更新数据就可以了。把主图K线加载到15根。指标完成后可以和其他分时图主图指标合并。本指标源码完成后归于雇主 ,不要加密成其他文件格式。     下面第1组是分时图主图K线指标,  引用和使用源码    如下,          第一组引用如下     O1:REF(O,1);

C1:REF(C,1);

H1:REF(H,1);

L1:REF(L,1);

O2:REF(O,2);

C2:REF(C,2);

H2:REF(H,2);

L2:REF(L,2);

O3:REF(O,3);

C3:REF(C,3);

H3:REF(H,3);

L3:REF(L,3);

O4:REF(O,4);

C4:REF(C,4);

H4:REF(H,4);

L4:REF(L,4);

O5:REF(O,5);

C5:REF(C,5);

H5:REF(H,5);

L5:REF(L,5);             下面是第一组使用公式 使用公式如下    DRAWTEXT_FIX(1,0,0.70,0,HYBLOCK),COLORYELLOW;

O5:="分时引用.O5#DAY";

C5:="分时引用.C5#DAY";

H5:="分时引用.H5#DAY";

L5:="分时引用.L5#DAY";

O4:="分时引用.O4#DAY";

C4:="分时引用.C4#DAY";

H4:="分时引用.H4#DAY";

L4:="分时引用.L4#DAY";

O3:="分时引用.O3#DAY";

C3:="分时引用.C3#DAY";

H3:="分时引用.H3#DAY";

L3:="分时引用.L3#DAY";

O2:="分时引用.O2#DAY";

C2:="分时引用.C2#DAY";

H2:="分时引用.H2#DAY";

L2:="分时引用.L2#DAY";

O1:="分时引用.O1#DAY";

C1:="分时引用.C1#DAY";

H1:="分时引用.H1#DAY";

L1:="分时引用.L1#DAY";

O0:=DYNAINFO(4);

C0:=DYNAINFO(7);

H0:=DYNAINFO(5);

L0:=DYNAINFO(6);

HH1:=MAX(H1,H2);

HH2:=MAX(H3,H4);

HH3:=MAX(MAX(H0,H5),MAX(HH1,HH2));

LL1:=MIN(L1,L2);

LL2:=MIN(L3,L4);

LL3:=MIN(MIN(L0,L5),MIN(LL1,LL2));

HL:=998/(HH3-LL3)/3;

C52:=998-((C5-LL3)*HL);

H52:=998-((H5-LL3)*HL);

L52:=998-((L5-LL3)*HL);

O52:=998-((O5-LL3)*HL);

C42:=998-((C4-LL3)*HL);

H42:=998-((H4-LL3)*HL);

L42:=998-((L4-LL3)*HL);

O42:=998-((O4-LL3)*HL);

C32:=998-((C3-LL3)*HL);

H32:=998-((H3-LL3)*HL);

L32:=998-((L3-LL3)*HL);

O32:=998-((O3-LL3)*HL);

C22:=998-((C2-LL3)*HL);

H22:=998-((H2-LL3)*HL);

L22:=998-((L2-LL3)*HL);  

O22:=998-((O2-LL3)*HL);

C12:=998-((C1-LL3)*HL);

H12:=998-((H1-LL3)*HL);

L12:=998-((L1-LL3)*HL);  

O12:=998-((O1-LL3)*HL);

C02:=998-((C0-LL3)*HL);

H02:=998-((H0-LL3)*HL);

L02:=998-((L0-LL3)*HL);

O02:=998-((O0-LL3)*HL);

DRAWRECTREL(8,H52,8,L52,RGB(IF(C5>=O5,200,0),IF(C5>=O5,0,200),0));

DRAWRECTREL(0,C52,16,O52,RGB(IF(C5>=O5,128,0),IF(C5>=O5,0,128),0));

DRAWRECTREL(28,H42,28,L42,RGB(IF(C4>=O4,200,0),IF(C4>=O4,0,200),0));

DRAWRECTREL(20,C42,36,O42,RGB(IF(C4>=O4,128,0),IF(C4>=O4,0,128),0));

DRAWRECTREL(48,H32,48,L32,RGB(IF(C3>=O3,200,0),IF(C3>=O3,0,200),0));

DRAWRECTREL(40,C32,56,O32,RGB(IF(C3>=O3,128,0),IF(C3>=O3,0,128),0));

DRAWRECTREL(68,H22,68,L22,RGB(IF(C2>=O2,200,0),IF(C2>=O2,0,200),0));

DRAWRECTREL(60,C22,76,O22,RGB(IF(C2>=O2,128,0),IF(C2>=O2,0,128),0));

DRAWRECTREL(88,H12,88,L12,RGB(IF(C1>=O1,200,0),IF(C1>=O1,0,200),0));

DRAWRECTREL(80,C12,96,O12,RGB(IF(C1>=O1,128,0),IF(C1>=O1,0,128),0));

DRAWRECTREL(108,H02,108,L02,RGB(IF(C0>=O0,200,0),IF(C0>=O0,0,200),0));

DRAWRECTREL(100,C02,116,O02,RGB(IF(C0>=O0,128,0),IF(C0>=O0,0,128),0));         下面是第二组,把下面这个第二组源码合并到第一组     JRH:=HHV(C,2);

JRL:=LLV(C,2);

MA3:=MA(CLOSE,3);

YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;

VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);

红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

卖:=IF(红色持股,JRL,DRAWNULL);

明卖价:=卖,COLORFF99FF,NODRAW;

今卖价:REF(卖,1)COLOR0000FF,NODRAW;

青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;

进:=IF(青色观望,JRH,DRAWNULL);

明进场价:=进,COLOR33AACC,NODRAW;

今进场价:REF(明进场价,1),COLORFF0000,NODRAW;

大单买:VAR19,COLOR33AACC,NODRAW;

大单卖:VAR1A,COLORFF99FF,NODRAW;

急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;

CO:=(C-O);

STICKLINE(大单买,O,O+CO/3,2.8,0),COLOR335555;

STICKLINE(大单买,O,O+CO/3,2,0),COLOR338888;

STICKLINE(大单买,O,O+CO/3,1.5,0),COLOR33AAAA;

STICKLINE(大单买,O,O+CO/3,1,0),COLOR33CCCC;

STICKLINE(大单买,O,O+CO/3,0,0),COLOR33EEEE;

DRAWTEXT(大单买,REF(CLOSE,1),''),COLOR33FFCC;

STICKLINE(大单卖,O,O+CO/3,2.8,0),COLOR550055;

STICKLINE(大单卖,O,O+CO/3,2,0),COLOR880088;

STICKLINE(大单卖,O,O+CO/3,1.5,0),COLORAA00AA;

STICKLINE(大单卖,O,O+CO/3,1,0),COLORCC00CC;

STICKLINE(大单卖,O,O+CO/3,0.5,0),COLOREE00EE;

DRAWTEXT(大单卖,REF(CLOSE,1)+0.1,''),COLORFF99FF;
附件: 您需要 才可以下载或查看,没有帐号?

举报

使用道具 扔鸡蛋

2673380
Lv.6

专栏

发表于 2022-7-13 08:37 复制 查看全部楼层 屏蔽
已采纳
附件: 您需要 才可以下载或查看,没有帐号?

举报

使用道具 支持 扔鸡蛋

2673380
Lv.6

专栏

发表于 2022-7-13 07:31 复制 查看全部楼层 屏蔽
已拒绝
该稿件已被甲方拒绝,理由是:
多了
附件: 您需要 才可以下载或查看,没有帐号?

举报

使用道具 点亮 支持 扔鸡蛋

您需要登录后才可以回帖

本版积分规则 《免责声明》

楼主
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表